866-974-3946

News

Prevail v9 on the horizon

By the end of the year, Prevail v9 will be available. In October, we will announce the changes being made. This version, while internally referred to as “v9,” is actually version-less going forward. In future, when we add features or integrations, they will go live to everyone after testing. That means there is no more waiting years to see a new feature. We plan on rolling out 4-6 new features and integrations per year.

There will be some changes to how we price Prevail. Prevail v9 will require an annual support contract to use the new features, and to get any additional features added after initial release. This is necessary because, as we move toward a software-as-a-service model like most of the industry, the integrations cause us to constantly track changes to other code bases and quickly adapt when the partner software changes (so that it keeps working with Prevail).

We expect everyone will be very pleased with v9, which has more additions and enhancements than any previous version. Expect more details in October!

Get Trained in SSD

Ormson Law Training is offering the most comprehensive and immersive online course for new disability claimant’s representatives. The Practice of Social Security Disability Law combines the basics of Social Security Disability Law with the practical skills commonly performed on the job.

While the entire course is best suited for new representatives, the course is divided into two parts to fit your training needs. Course instructors include retired ALJs, retired law professors, former DDS employees, and current practitioners. Ormson Law Training creates more job-ready representatives for your practice so you focus on fee-generating activities.

Act now! Visit https://www.ormsonlawtraining.com/courses, and select the course that fits your training needs.

New cyber threat identified – get your server up to date!

There is a new BlueKeep exploit virus out there, and it can infect all networked PCs, especially those running Windows Server 2008 or prior.

More info from Ars Technica: https://arstechnica.com/information-technology/2019/06/new-bluekeep-exploit-shows-the-wormable-danger-is-very-very-real/

As usual, the best remedy is to update your software, and even better to update your server version.

©2019 practice technology inc.
About Us Contact Us Events Partners ©2018 practice technology inc.